rails 3 Installing pg (0.11.0) with native extensions Unfortunately, a fatal error has occurred. Please report this error to the Bundler issue tracker at https://github.com/carlhuda/bundler/issues so that we can fix it. Thanks!

14.36 Muhamad Akbar Bin Widayat 0 Comments

Installing pg (0.11.0) with native extensions Unfortunately, a fatal error has occurred. Please report this error to the Bundler issue tracker at https://github.com/carlhuda/bundler/issues so that we can fix it. Thanks!
/home/lap048/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:552:in `rescue in block in build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)

        /home/lap048/.rvm/rubies/ruby-1.9.2-p180/bin/ruby extconf.rb --with-pg-config=/usr/local/Cellar/postgresql/9.1.2/bin/pg_config
Using config values from /usr/local/Cellar/postgresql/9.1.2/bin/pg_config
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
 --with-opt-dir
 --with-opt-include
 --without-opt-include=${opt-dir}/include
 --with-opt-lib
 --without-opt-lib=${opt-dir}/lib
 --with-make-prog
 --without-make-prog
 --srcdir=.
 --curdir
 --ruby=/home/lap048/.rvm/rubies/ruby-1.9.2-p180/bin/ruby
 --with-pg
 --without-pg
 --with-pg-dir
 --without-pg-dir
 --with-pg-include
 --without-pg-include=${pg-dir}/include
 --with-pg-lib
 --without-pg-lib=${pg-dir}/lib
 --with-pg-config
extconf.rb:24:in ``': No such file or directory - /usr/local/Cellar/postgresql/9.1.2/bin/pg_config --includedir (Errno::ENOENT)
 from extconf.rb:24:in `
' Gem files will remain installed in /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/pg-0.11.0 for inspection. Results logged to /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/pg-0.11.0/ext/gem_make.out from /home/lap048/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:530:in `block in build_extensions' from /home/lap048/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:505:in `each' from /home/lap048/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:505:in `build_extensions' from /home/lap048/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:180:in `install' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/source.rb:90:in `block in install' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/rubygems_integration.rb:82:in `preserve_paths' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/source.rb:89:in `install' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/installer.rb:73:in `block in install_gem_from_spec' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/rubygems_integration.rb:97:in `with_build_args' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/installer.rb:72:in `install_gem_from_spec' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/installer.rb:56:in `block in run' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/installer.rb:55:in `run' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/installer.rb:12:in `install' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/cli.rb:220:in `install' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/vendor/thor/task.rb:22:in `run' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/vendor/thor/invocation.rb:118:in `invoke_task' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/vendor/thor.rb:263:in `dispatch' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/lib/bundler/vendor/thor/base.rb:386:in `start' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/gems/bundler-1.1.rc.8/bin/bundle:13:in `' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/bin/bundle:19:in `load' from /home/lap048/.rvm/gems/ruby-1.9.2-p180@threeone1/bin/bundle:19:in `
'

It is error
1.So you must delete your gemfile
2. next you must bundle install again
3. Gemfile git pull and git push to server again if you use git

0 komentar:

terimakasih komentarnya